Radio Sanfurgo en espera de la licencia de la SCD
Sin transmisión en estos momentos
El tiempo en Santa Cruz

Aplicar color automáticamente a una fila en Excel según el día de semana de una celda.

viernes, 2 de junio de 2017

He recibido esta solicitud por el formulario de contacto
"Hola, si tengo una serie de fechas en la columna A y quiero que todas las filas que pertenezcan a un determinado día queden de un color como lo puedo hacer?, por ejemplo: todas las filas de días lunes rojas, las filas de días martes verdes y así. Quedo atento. Gracias! "
---
Le he planteado al lector esta posible solución:
Supongamos que en la columna A tienes las fechas escritas desde A2 hacia abajo, en el formato de tu preferencia, por ejemplo 22-may
Usemos una columna auxiliar, por ejemplo la columna L
En L2 escribimos esta fórmula  =TEXTO(A2;"DDDD") y la copiamos hacia abajo hasta donde la necesites, por ejemplo hasta L20
Ahora vamos a formato condicional y en "utilice una fórmula para ..." escribir esta fórmula  =($L2="lunes") si queremos que la fila con el día lunes tome un color determinado
Elegimos el color que tendrá la fila y aceptamos. 
En el siguiente recuadro escribimos hasta donde tomará ese color la fila y qué sector de nuestra zona de trabajo quedará afecta al formato condicional. Supongamos que hasta la columna L y hasta la fila 20
Escribimos =$A$2:$L$20 y aceptamos
Ahora hasta la fila 20 se teñirán del color elegido cada vez que mi fecha corresponda al día lunes.
Lo mismo servirá si queremos que otros días tengan otro color
---
NOTA: 
1. Podemos ocultar la columna L para que no aparezca como parte de nuestra planilla de trabajo
2. Si queremos evitar que la columna L nos muestre un resultado cuando en la columna A no haya ningún dato, podemos cambiar la fórmula por la siguiente:
=SI(A2="";"";TEXTO(A2;"DDDD"))
3. Si lo desea puede bajar una planilla de ejemplo desde aquí


- - - - -

ENCUESTA TV


CONTACTO

foxyform