RADIO SANFURGO - SANTA CRUZ CHILE
RADIO SANFURGO, AMBIENTE MUSICAL CLÁSICO
SANTA CRUZ, COLCHAGUA, CHILE
Radio online no comercial de Música Clásica las 24 horas, sin publicidad, sin interrupciones

Aplicar color automáticamente a una fila en Excel según el día de semana de una celda.

viernes, 2 de junio de 2017

He recibido esta solicitud por el formulario de contacto
"Hola, si tengo una serie de fechas en la columna A y quiero que todas las filas que pertenezcan a un determinado día queden de un color como lo puedo hacer?, por ejemplo: todas las filas de días lunes rojas, las filas de días martes verdes y así. Quedo atento. Gracias! "
---
Le he planteado al lector esta posible solución:
Supongamos que en la columna A tienes las fechas escritas desde A2 hacia abajo, en el formato de tu preferencia, por ejemplo 22-may
Usemos una columna auxiliar, por ejemplo la columna L
En L2 escribimos esta fórmula  =TEXTO(A2;"DDDD") y la copiamos hacia abajo hasta donde la necesites, por ejemplo hasta L20
Ahora vamos a formato condicional y en "utilice una fórmula para ..." escribir esta fórmula  =($L2="lunes") si queremos que la fila con el día lunes tome un color determinado
Elegimos el color que tendrá la fila y aceptamos. 
En el siguiente recuadro escribimos hasta donde tomará ese color la fila y qué sector de nuestra zona de trabajo quedará afecta al formato condicional. Supongamos que hasta la columna L y hasta la fila 20
Escribimos =$A$2:$L$20 y aceptamos
Ahora hasta la fila 20 se teñirán del color elegido cada vez que mi fecha corresponda al día lunes.
Lo mismo servirá si queremos que otros días tengan otro color
---
NOTA: 
1. Podemos ocultar la columna L para que no aparezca como parte de nuestra planilla de trabajo
2. Si queremos evitar que la columna L nos muestre un resultado cuando en la columna A no haya ningún dato, podemos cambiar la fórmula por la siguiente:
=SI(A2="";"";TEXTO(A2;"DDDD"))
3. Si lo desea puede bajar una planilla de ejemplo desde aquí


2 comentarios

Unknown dijo...

hola, hice una planilla de ventas donde pongo las facturas que estan pagadas y las facturas que estan por cobrar, como hago para que la fila se ponga de un solo color al cambiar de estado, quiero las que estan por cobrar en un color y las pagadas en otro, la planilla contien, fecha, numero de factura, cliente, documento y monto.
me puede ayudar por favor?

12:38 p.m.
Jose Sanfurgo dijo...

Debe crear una columna donde escriba por ejemplo, frente a cada cliente, "Pagado" o "Por pagar" (sin las comillas)
Supongamos que elige la columna G.
Ahora crearemos dos formatos condicionales:
1. Nos ubicamos en la primera celda con datos. Supongamos que es A2
Vamos a Formato Condicional y en "utilice una fórmula para..." escribimos:
=($G2="Pagado")
En el mismo cuadro vamos más abajo a Formato y elegimos color de relleno (el que usted quiera) y aceptamos
Aceptamos nuevamente
En el cuadro siguiente vemos la fórmula y el color elegido y - donde dice - "Se aplica a" escribimos:
=$A$2:$G$100
CUIDADO: $A$2 aparece ya escrito. Tenga la precaución de borrar el 2 y volver a escribirlo para luego continuar escribiendo :$G$100.
NOTA entre A2 y G100 se rellenará del color elegido cada vez que escriba en la columna G, frente a un determinado cliente, "Pagado"

2. Para el otro formato debe ubicarse nuevamente en A2 y luego vaya a formato condicional y elija nueva regla.
A continuación repita todo el proceso anterior cambiando solamente "Por pagar" y eligiendo otro color en formato.

Espero que le resulte muy bien. Saludos

3:06 a.m.

Publicar un comentario

- - - - -